This project is read-only.

iFrame buttons not working issue

Oct 19, 2009 at 4:24 PM

Hi sanshi, great stuff. I spent a couple hours with a problem on the modal windows and finally figured it out, might be helpful for others. I copied and pasted some of the examples that came with the project and Visual Studio was auto creating an ID for the <head> tags. It turns out that if the IDs for the head tags are the same for both the parent and popup window's iframe page, the buttons will not work in the iframe page and you cant post or close the modal window. (ie. button_iframe.aspx & iframe_iframe_run_window1.aspx had the same id="head1" in the head tag)

Oct 19, 2009 at 5:58 PM
Edited Oct 20, 2009 at 5:56 AM

Hi, one thing, is there a way to change the tooltip on the x button in the top right corner of the modal popup? There seems to be a default in there... Thx!

Oct 20, 2009 at 2:10 AM

hi thebox, I follow your steps - set button_iframe.aspx & iframe_iframe_run_window1.aspx with the same id "head1" - and no error was found.

Actually, they are two different pages and I don't think they will conflict with each other. Would you mind check it again?

Oct 20, 2009 at 2:29 AM
thebox wrote:

Hi, one thing, is there a way to change the tooltip on the x button in the top right corner of the modal popup? There seems to be a default in there... Thx!

I notice a mistake in the x button tooltip, which always show Chinese text even the lang is English. I will fix it next version.

 

You can modify the x button tooltip using Javascript:

<script type="text/javascript">
    function onReady() {
        var window1 = Ext.getCmp('<%= Window1.ClientID %>');
        window1.getTool("close").dom.qtip = "Close this window!";
    }
</script>